CMakeLists in Ubuntu wily

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

CMakeLists in Ubuntu wily

Israel-28
Hi everyone,
I have been trying to get lmms 1.1.3 into Ubuntu Wily, with the separate
VST package, but we are having issues with CMake.
Timo and I have been commenting about this:
https://code.launchpad.net/~israeldahl/ubuntu/wily/lmms/lmms/+merge/266928

My guess is that CMake
3.3.X is not handling things correctly in Ubuntu wily.
Your CMakeLists looks for:
CMAKE_MINIMUM_REQUIRED(VERSION 2.4.5)
So there obviously has been many changes since then.
Does it work for anyone to use the latest 3.3.X version of cmake in
their own environments?

The other issue we might face is the newer gcc version.....

But the errors we have found have been related to Cmake thus far.

Initially cmake could not find FLUID, even though I include the fluid
binary as part of the build depends (in the debian packaging) and it
does exist in the build environment in the usual place (/usr/bin/fluid)
Here is what Timo did to force it to find Fluid:

FIND_PACKAGE(FLTK REQUIRED)
+
++SET(FLTK_FLUID_EXECUTABLE "/usr/bin/fluid")
+ IF(MINGW_PREFIX)
+ SET(FLTK_FLUID_EXECUTABLE "${MINGW_PREFIX}/bin/fluid")
+ ENDIF()

After this is fails at

CMakeFiles/Makefile2:4654: recipe for target 'plugins/LadspaEffect/swh/CMakeFiles/hermes_filter_1200.dir/all' failed

And other plugins fail as well.
So... anyone have any suggestions for this?

--
Regards


------------------------------------------------------------------------------
_______________________________________________
LMMS-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/lmms-devel
Loading...